JNI UnsatisfiedLinkError when running ant sample on OSX 10.8.4

asked 2013-07-17 07:42:17 -0500

omaraa gravatar image

I'm encountering an issue similar to this but with a different operating system - http://answers.opencv.org/question/14803/jni-unsatisfiedlinkerror-when-running-ant-sample/

When I run the ant sample from the OpenCV Introduction to Java Development tutorial, I get this output:

Welcome to OpenCV
Exception in thread "main" java.lang.UnsatisfiedLinkError: org.opencv.core.Mat.n_Mat(IIIDDDD)J
at org.opencv.core.Mat.n_Mat(Native Method)
at org.opencv.core.Mat.<init>(Mat.java:535)
at SimpleSample.main(SimpleSample.java:12)

My system is running:

System Version: OS X 10.8.4 (12E55)
Kernel Version: Darwin 12.4.0


java version "1.7.0_25" Java(TM) SE
Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

I also encounter the same error with opencv versions and 2.4.5.

Can anyone suggest how I might get this working?

edit retag flag offensive close merge delete