Make Issue: CMake detected only python interpreter and python module unavaliable [closed]

asked 2017-07-23 04:02:12 -0500

yiranwu gravatar image

updated 2017-07-23 04:55:52 -0500

I'm trying to install opencv3.2 with python2.7.6, anaconda2, CUDA 8.0, CuDNN 6.0, and Ubuntu 14.04 64bit. Running the following

cmake -D CMAKE_BUILD_TYPE=RELEASE -D CMAKE_INSTALL_PREFIX=/usr/local -D INSTALL_C_EXAMPLES=ON -D INSTALL_PYTHON_EXAMPLES=ON -D OPENCV_EXTRA_MODULES_PATH=~/opencv_contrib/modules -D BUILD_EXAMPLES=ON ..

I get opencv configuration saying

-- OpenCV modules:

-- To be built: (omitted)

-- Disabled: world contrib_world

-- Disabled by dependency: -

-- Unavailable: java python2 python3 viz cnn_3dobj cvv matlab sfm

(omitted)

-- Python 2:

-- Interpreter: /home/wyr/anaconda2/bin/python2.7 (ver 2.7.13)

--

-- Python 3:

-- Interpreter: /usr/bin/python3.4 (ver 3.4.3)

which shows python2 support is unavaliable. (By the way, if I ignore this and go on to make, it terminates normally but without python2 support.)

Following this tutorial link text I think get python interpreter&library&numpy&package_path might work.

Then I worked on this and tried:

  1. explicitly specify those path by sonething like -D PYTHON2_LIBRARY=/usr/lib/x86_64-linux-gnu/libpython2.7.so
  2. upgrade cmake to the latest ver, as another post suggests

but nothing changes.

Can anyone help, please?

Fixed. Switching from anaconda python interpreter to builtin python works for me.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by yiranwu
close date 2017-07-23 04:57:00.701683