Ask Your Question
0

Using OpenCV + OpenNI2.2 + ASUS Xtion2 depth sensor

asked 2017-07-07 10:28:22 -0500

klapperj gravatar image

updated 2017-07-07 14:39:29 -0500

I have a .cpp program running with an Xbox 360 Kinect through a combination of OpenCV3.0 + OpenNI1.5 + SensorKinect on Ubuntu 14.04 LTS. The program runs great with no issues. I am now trying to run this program with a newer sensor(ASUS Xtion2). I have spent a considerable amount of time with this project and cannot figure out the compatability.

I can get the sensor to work with all OpenNI2.2 programs such as NiViewer, SimpleViewer, SimpleRead, etc. The version of OpenNI2.2 I installed is here: https://github.com/occipital/OpenNI2 . I installed OpenCV3.2 from here http://opencv.org/releases.html and ran cmake with the "WITH_OPENNI2" flag set. OpenCV is able to recognize the OpenNI2.2 package when I run "make".

When I try to run the program the sensor is recognized and these messages are shown:

Video Camera at /dev/video1 Detected 
Depth Camera at /dev/video0 Detected 
Creating Depth stream 
Depth Stream start 
Xtion2 sensor found! 
Depth Stream stop

The program begins to access the sensor and then immediately shuts off. I have added the "Xtion2 sensor found!" message to print when the depth sensor is accessed by OpenCV. I cannot figure out why the camera shuts off. Because the Xtion2 sensor is new, I cannot find much help with this online. I am wondering if this sensor will be able to work with the combination of OpenNI2.2 and OpenCV3.2 to retrieve the RGB and depth data from the sensor.

Don't hesitate to ask questions because I most likely have the answers. I am just not sure the in-depth information that is needed to fully understand what isn't working.

I would appreciate any help I can get. Thanks!

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2018-10-22 01:36:04 -0500

Passta gravatar image

Hey, does anyone of you have new information on this topic? My Camera also works with the NiViewer (Windows 10, Asus Xtion Pro, OpenCV for Python) but if i try to access the sensor it immediately stops the execution of the programm but doesn´t show an error message.

I would be grateful for any help :-)

edit flag offensive delete link more
0

answered 2017-09-21 05:12:35 -0500

Rok gravatar image

Hi, I have the same problem..so this is not a real solution but anyway.. The provided examples, like NiViewer crashes. I tried on different computers with different Ubuntu version (14, 16), I managed to run it only on my computer, but only lowering the bandwidth as they suggest in the manual (however this solution doesn't work in any of the other computers I tested. It is due to a bandwidth problem. I am in contact with the support service and they told me that they are working for a solution, probably to be released as new firmware in August. Rigth now there are still no new firmware upgrade and they don't reply to my email..

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-07-07 10:25:26 -0500

Seen: 897 times

Last updated: Sep 21 '17