Opencv 2.4.5 does not build with java bindings on Centos 6.4

asked 2013-07-08 13:43:00 -0500

ctong gravatar image

updated 2013-07-08 13:45:24 -0500

image description image description

From what I have read it seems to be a problem with the my JNI, but I have checked and have JNI (Checked using command: find / -name jni.h). It builds correctly if I go to /opencv-2.4.5/modules/java/CmakeLists.txt and delete part of the fourth line that reads (JNI_FOUND OR (ANDROID AND ANDROID_NATIVE_API_LEVEL GREATER 7))). I did the ant sample using the resulting build and it worked, however I don't want to move forward with this fix because it seems like I will run into problems later on. Next I tried going into /opencv-2.4.5/CmakeLists.txt and looking for the variable JNI_FOUND. It looks like JNI_FOUND results from a findpackage(JNI) command. I think this maybe the problem because JNI is not a package. I believe that a findpath command would fix this issue

edit retag flag offensive close merge delete

Comments

sounds like you want to report that here

berak gravatar imageberak ( 2013-07-08 13:53:41 -0500 )edit

thank you I posted it

ctong gravatar imagectong ( 2013-07-08 14:48:21 -0500 )edit