invalid option, /FIC

asked 2017-07-02 16:27:15 -0500

Humam Helfawi gravatar image

I am trying to build OpenCV 3.2 using Visual studio 2017 comminuty edition. I am building without CUDA and all other options are kept as default.

I am getting this error while bulding:

Severity    Code    Description Project File    Line    Suppression State
Error   RC1103  invalid option, /FIC:/opencv/modules/videostab/src/precomp.hpp  opencv_videostab    C:\opencv\_build\modules\videostab\RC   1

It is also happens in other modules.

BTW during Cmake stage I got this warnings:

CMake Deprecation Warning at CMakeLists.txt:81 (cmake_policy):
  The OLD behavior for policy CMP0020 will be removed from a future version
  of CMake.

  The cmake-policies(7) manual explains that the OLD behaviors of all
  policies are deprecated and that a policy should be set to OLD only under
  specific short-term circumstances.  Projects should be ported to the NEW
  behavior and not rely on setting a policy to OLD.


CMake Deprecation Warning at CMakeLists.txt:85 (cmake_policy):
  The OLD behavior for policy CMP0022 will be removed from a future version
  of CMake.

  The cmake-policies(7) manual explains that the OLD behaviors of all
  policies are deprecated and that a policy should be set to OLD only under
  specific short-term circumstances.  Projects should be ported to the NEW
  behavior and not rely on setting a policy to OLD.


CMake Deprecation Warning at CMakeLists.txt:94 (cmake_policy):
  The OLD behavior for policy CMP0026 will be removed from a future version
  of CMake.

  The cmake-policies(7) manual explains that the OLD behaviors of all
  policies are deprecated and that a policy should be set to OLD only under
  specific short-term circumstances.  Projects should be ported to the NEW
  behavior and not rely on setting a policy to OLD.
edit retag flag offensive close merge delete

Comments

1

Using vs 2017 for module videostab there is no problem. Try to clean your solution before compiling. If problem is still here uncheck ENABLE_PRECOMPILED_HEADERS in cmake

LBerger gravatar imageLBerger ( 2017-07-02 16:56:50 -0500 )edit

I had the same problem and your solution worked. Why should we do that ?

gadcam gravatar imagegadcam ( 2017-07-02 19:18:45 -0500 )edit

Which solution ? 1- clean or 2-ENABLE_PRECOMPILED_HEADERS

LBerger gravatar imageLBerger ( 2017-07-03 02:14:58 -0500 )edit

The solution was to uncheck ENABLE_PRECOMPILED_HEADERS in CMake. Cleaning won't help, alone at least.

gadcam gravatar imagegadcam ( 2017-07-03 02:44:01 -0500 )edit

I haven't got to investigate more today But I run cmake and compile opencv using VS2017 without problem

LBerger gravatar imageLBerger ( 2017-07-03 07:06:42 -0500 )edit

@LBreger, Bulding without precompiled headers solved the problem. However, I could not mange to do it without this option. thank you very much

Humam Helfawi gravatar imageHumam Helfawi ( 2017-07-08 19:32:48 -0500 )edit

Can you try using cmake 3.7?

LBerger gravatar imageLBerger ( 2017-07-09 01:20:52 -0500 )edit

FYI in my case I was using CMake 3.9.0-rc5.

gadcam gravatar imagegadcam ( 2017-07-11 06:47:08 -0500 )edit

If you want really use vs 2017 use cmake 3.8.2 and wait may be 3.9.0 version (not a rc)

LBerger gravatar imageLBerger ( 2017-07-11 06:51:31 -0500 )edit