Problem with compiling and ts.hpp

asked 2017-06-27 13:54:50 -0500

narutocool gravatar image

updated 2017-06-30 03:57:57 -0500

Hi, I work on stereo vision and I need the extra module stereo so I deciced to make my own opencv bundle with this module. But when I make install my output file doesn't contain the ts file and I need it to test the sample. During the Cmake step, I check and the build opencv_ts is check. I think it's the same problem http://answers.opencv.org/question/13...

CMakeOutput : The system is: Linux - 4.4.0-81-generic - x86_64 Compiling the CXX compiler identification source file "CMakeCXXCompilerId.cpp" succeeded. Compiler: /usr/bin/c++ Build flags: Id flags:

The output was: 0

Compilation of the CXX compiler identification source "CMakeCXXCompilerId.cpp" produced "a.out"

The CXX compiler identification is GNU, found in "/usr/local/home/prousso/opencv_root/build_opencv/CMakeFiles/3.5.1/CompilerIdCXX/a.out"

Compiling the C compiler identification source file "CMakeCCompilerId.c" succeeded. Compiler: /usr/bin/cc Build flags: Id flags:

The output was: 0

Compilation of the C compiler identification source "CMakeCCompilerId.c" produced "a.out"

The C compiler identification is GNU, found in "/usr/local/home/prousso/opencv_root/build_opencv/CMakeFiles/3.5.1/CompilerIdC/a.out"

Determining if the CXX compiler works passed with the following output: Change Dir: /usr/local/home/prousso/opencv_root/build_opencv/CMakeFiles/CMakeTmp

Run Build Command:"/usr/bin/make" "cmTC_5e8e8/fast" /usr/bin/make -f CMakeFiles/cmTC_5e8e8.dir/build.make CMakeFiles/cmTC_5e8e8.dir/build make[1] : on entre dans le répertoire « /usr/local/home/prousso/opencv_root/build_opencv/CMakeFiles/CMakeTmp » Building CXX object CMakeFiles/cmTC_5e8e8.dir/testCXXCompiler.cxx.o /usr/bin/c++ -o CMakeFiles/cmTC_5e8e8.dir/testCXXCompiler.cxx.o -c /usr/local/home/prousso/opencv_root/build_opencv/CMakeFiles/CMakeTmp/testCXXCompiler.cxx Linking CXX executable cmTC_5e8e8 /usr/bin/cmake -E cmake_link_script CMakeFiles/cmTC_5e8e8.dir/link.txt --verbose=1 /usr/bin/c++ CMakeFiles/cmTC_5e8e8.dir/testCXXCompiler.cxx.o -o cmTC_5e8e8 -rdynamic make[1] : on quitte le répertoire « /usr/local/home/prousso/opencv_root/build_opencv/CMakeFiles/CMakeTmp »

Detecting CXX compiler ABI info compiled with the following output: Change Dir: /usr/local/home/prousso/opencv_root/build_opencv/CMakeFiles/CMakeTmp

Run Build Command:"/usr/bin/make" "cmTC_91347/fast" /usr/bin/make -f CMakeFiles/cmTC_91347.dir/build.make CMakeFiles/cmTC_91347.dir/build make[1] : on entre dans le répertoire « /usr/local/home/prousso/opencv_root/build_opencv/CMakeFiles/CMakeTmp » Building CXX object CMakeFiles/cmTC_91347.dir/CMakeCXXCompilerABI.cpp.o /usr/bin/c++ -o CMakeFiles/cmTC_91347.dir/CMakeCXXCompilerABI.cpp.o -c /usr/share/cmake-3.5/Modules/CMakeCXXCompilerABI.cpp Linking CXX executable cmTC_91347 /usr/bin/cmake -E cmake_link_script CMakeFiles/cmTC_91347.dir/link.txt --verbose=1 /usr/bin/c++ -v CMakeFiles/cmTC_91347.dir/CMakeCXXCompilerABI.cpp.o -o cmTC_91347 -rdynamic Using built-in specs. COLLECT_GCC=/usr/bin/c++ COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/5/lto-wrapper Target: x86_64-linux-gnu Configured with: ../src/configure -v --with-pkgversion='Ubuntu 5.4.0-6ubuntu1~16.04.4' --with-bugurl=file:///usr/share/doc/gcc-5/README.Bugs --enable-languages=c,ada,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-5 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time ... (more)

edit retag flag offensive close merge delete

Comments

can you post cmake output

LBerger gravatar imageLBerger ( 2017-06-27 14:17:22 -0500 )edit

let's start here:

doesn't contain the ts file and I need it to test the sample

this is not true. you need the ts library to build & run the opencv library unit tests, but not for the samples. (it also should not be neeeded from any of your code)

berak gravatar imageberak ( 2017-06-30 02:52:23 -0500 )edit