Ask Your Question
0

Cmake Errors

asked 2017-05-10 12:41:21 -0500

Hi guys, I'm using CMAKE-GUI to configure and generate the files for installing OPENCV and link it with my Qt 5.8. I'm doing it on a Ubuntu 16.04 system, using opencv 3.2.0 and opencv_contrib 3.2.0

Apparently I'm having several errors related to the opencv_contrib usage. I've already Configurate OPENCV using CMAKE-GUI, without the CONTRIB modules and everything went all right. But I've tried to add the contrib modules a few times and was never able to do it. So, I've uninstalled everything and I'm doing it from the scratch.

I'm still having several errors and I didn't find any help to them so far. I'll be linking the several errors below.

CMake Error at .../opencv-3.2.0-source/cmake/OpenCVUtils.cmake:1005 (file): file MD5 failed to read file ".../opencv/opencv-3.2.0-debug/3rdparty/protobuf/": Sucess Call Stack (most recent call first): ../opencv_contrib-master/modules/dnn/cmake/OpenCVFindLibProtobuf.cmake:32 (ocv_download) ../opencv_contrib-master/modules/dnn/CMakeLists.txt:5 (include)

Downloading ... CMake Error at .../opencv-3.2.0-source/cmake/OpenCVUtils.cmake:1043 (file): file DOWNLOAD cannot open file for write. Call Stack (most recent call first): .../opencv_contrib-master/modules/dnn/cmake/OpenCVFindLibProtobuf.cmake:32 (ocv_download) .../opencv_contrib-master/modules/dnn/CMakeLists.txt:5 (include)

CMake Error at .../opencv-3.2.0-source/cmake/OpenCVUtils.cmake:1047 (message): Failed to download . Status= Call Stack (most recent call first): /h.../opencv_contrib-master/modules/dnn/cmake/OpenCVFindLibProtobuf.cmake:32 (ocv_download) .../opencv_contrib-master/modules/dnn/CMakeLists.txt:5 (include)

edit retag flag offensive close merge delete

Comments

I have same problem. are you resolve it?

anhnamxtanh gravatar imageanhnamxtanh ( 2017-06-17 17:57:50 -0500 )edit

Is necessary to remove this from includes. I use OpenCV 3.1 and I removed it and now all is well :D That's my solution. For me was a good solution :D @anhnamxtanh

Laurentiu gravatar imageLaurentiu ( 2017-08-03 01:01:35 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-05-11 10:47:06 -0500

Laurentiu gravatar image

Is necessary to remove this from includes. I use OpenCV 3.1 and I removed it and now all is well :D

edit flag offensive delete link more

Comments

Thanks for the answer. In fact, I've downloaded protobuff from their github, but now I'm with errors on other downloads. It seems that my cmake+opencv cannot download dependencies. Anyway, I'll be unchecking all unnecessary modules from contrib.

TMiranda gravatar imageTMiranda ( 2017-05-12 08:39:27 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-05-10 12:41:21 -0500

Seen: 749 times

Last updated: May 10 '17