Ask Your Question
0

opencv2/core/ultility.hpp not found

asked 2013-06-06 04:57:49 -0500

supergate gravatar image

Hello, I have been very interested in studying Facial Recognition and a good friend of mine had me look into openCV. I can get most of the tutorials to work while learning to use openCV but when I need to use

#include <opencv2/core/utility.hpp>

I receive an error saying it cannot be found, I looked into the folder and its not there? and this is coming from a fresh copy of openCV off of github. Where or how can I fix not having the utility.hpp?

edit retag flag offensive close merge delete

Comments

which opencv version ? (lots of changes going on on master)

berak gravatar imageberak ( 2013-06-06 04:59:52 -0500 )edit

opencv/modules/core/include/opencv2/core/utility.hpp, not there ?

berak gravatar imageberak ( 2013-06-06 05:52:55 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
2

answered 2013-06-06 05:14:58 -0500

berak gravatar image

a lot of utility functions like format() have been moved from opencv2/core/core.hpp to opencv2/core/utility.hpp in master.

if you can't find that header with your install, my guess is, that you're on 2.4.5, but trying the sample from master.

please try the 2.4 facerec sample instead, and report.

edit flag offensive delete link more

Comments

actually I had built from the 2.4.9. I also noticed that when I installed opencv on a different computer, it behaved differently and actually added the utility.hpp to to opencv2/core/utility.hpp.

however instead of it doing /build/x86/vc10/ it doesn't add that at all?

supergate gravatar imagesupergate ( 2013-06-07 06:30:51 -0500 )edit

sorry, did not understand your last question

berak gravatar imageberak ( 2013-06-07 08:45:20 -0500 )edit

on the demo, I need to create a CSV, the data in that file, would it be the paths to the image? or?

supergate gravatar imagesupergate ( 2013-06-09 08:30:28 -0500 )edit

nvm I found my answer on the CSV.

when I tried to build OpenCV on the 2.4.9 it behaved differently on my laptop then it did on my computer. Instead of having opencv/build/x86/vc10/lib, it doesn't give me that directory at all. I tried to rebuild it with cmake and vs c++ but the outcome keeps staying the same.

however the 2.4 facerec sample that you had linked to me works great-ish on 2.4.5. I built my CSV and plugged it into the command line

Facerec_demo.exe at.txt

and it stats working, loads a screen that's blue and white and gray on the rest of the screen, and just sits there forever not doing anything.

supergate gravatar imagesupergate ( 2013-06-09 12:14:05 -0500 )edit

Hello , I have same problem. And I dont understand your solution. There isnot the utility.hpp In my opencv2 folder.

jossyy gravatar imagejossyy ( 2014-03-20 06:23:06 -0500 )edit

I have the same problem. The only utility.hpp is in /opencv2/gpu/device. I'm trying to run the example code for camera calibration, which uses it (https://github.com/Itseez/opencv/blob/master/samples/cpp/calibration.cpp). Using a compiled from source 2.4.8.

rbaleksandar gravatar imagerbaleksandar ( 2014-04-16 11:18:30 -0500 )edit

Guys, this file exists only in master (OpenCV 3.0), so, please use it.

Daniil Osokin gravatar imageDaniil Osokin ( 2014-11-12 08:00:18 -0500 )edit

You do realize that sometimes an upgrade of the system is not desired, right? :)

rbaleksandar gravatar imagerbaleksandar ( 2014-11-13 14:20:47 -0500 )edit

You do realize that sometimes an upgrade is not possible/desirable, right?

rbaleksandar gravatar imagerbaleksandar ( 2014-11-13 14:22:40 -0500 )edit

@rbaleksandar , for 2.4, just use the appropriate sample code

berak gravatar imageberak ( 2014-11-13 14:25:27 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2013-06-06 04:57:49 -0500

Seen: 8,541 times

Last updated: Jun 06 '13