Ask Your Question
0

interactive charuco application fails...

asked 2017-04-26 15:18:52 -0500

stillNovice gravatar image

Hi, i have built the sample app opencv_interactive-calibration.exe and it will run ok on a webcam (although every frame is rejected, I assume the webcam is too low res)

I have a higher resolution video that i am trying to run, but when i run:

opencv_interactive-calibration.exe -v bmCalib.mov

in a cmd prompt, I get:

Hot keys:
esc - exit application
s - save current data to .xml file
r - delete last frame
u - enable/disable applying undistortion
d - delete all frames
v - switch visualization
Unable to open video source

The mov is in the same folder as the exe. i have tried converting to an avi, and I get the same issue. Can anyone help me out here?

Thanks!

edit retag flag offensive close merge delete

Comments

1

try: -v=bmCalib.mov (the = is important, similar for all other cmdline params)

berak gravatar imageberak ( 2017-04-27 01:35:35 -0500 )edit

hi, thanks for your reply. I am using opencv_interactive-calibration.exe -v=bmCalib.mov -t=charuco -pf=defaultConfig.xml -w=5 -h=7 -l=100 -s=10 -d=16 -sl=0.032 -ml=0.017 and see the same error.

antithing gravatar imageantithing ( 2017-04-27 04:17:31 -0500 )edit

".. the same error" -- which is ? you never mentioned any

berak gravatar imageberak ( 2017-04-27 11:36:22 -0500 )edit

Ah sorry, I mean that it just returns Unable to open video source.

antithing gravatar imageantithing ( 2017-04-27 11:44:29 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-04-28 04:13:34 -0500

antithing gravatar image

Ah, I had openCv built without ffmpeg support. Never noticed before because I always used image sequences! rebuilding all libs with ffmpeg has solved this. Thank you for your time.

edit flag offensive delete link more

Comments

thanks for coming back with an answer !

berak gravatar imageberak ( 2017-04-28 05:22:10 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-04-26 15:18:52 -0500

Seen: 215 times

Last updated: Apr 26 '17