Ask Your Question

Implements CvViewFrameListener2 not found

asked 2013-05-30 04:53:45 -0600

Vaska gravatar image

Hello, I need help i want add implements to my activity -> CvViewFrameListener2 - not found what is problem?

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted

answered 2013-06-26 06:09:41 -0600

berak gravatar image

you also have to add the opencv library to your project.

Properties / Android / library

add the OpenCV library 2.4.5 there

CvViewFrameListener2 is defined inside

edit flag offensive delete link more

answered 2013-06-26 07:24:50 -0600

advdk gravatar image

Thank you for your answer, berak. Solved it. Seems like the interface name is misspelled in the tutorial. Instead of CvViewFrameListener2 (which really doesn't exist) I used CvCameraViewListener2 and everything works like a charm.

edit flag offensive delete link more


ah, right . but please use comments, not answers !

berak gravatar imageberak ( 2013-06-26 07:28:15 -0600 )edit

answered 2013-06-26 05:55:17 -0600

advdk gravatar image

The same problem here. I tried to folllow this tutorial, but I got stuck at

11 Defines that your activity implements CvViewFrameListener2 interface (...)

It seems like the interface CvViewFrameListener2 doesn't exist in OpenCV library. Has anybody any idea?

edit flag offensive delete link more

answered 2013-05-30 09:00:46 -0600

Awkman gravatar image

Do you have the "OpenCV Library - 2.x.x" Project "imported" and "open" in eclipse ?

If you don't I think you get errors like that on every reference to an opencv class.

edit flag offensive delete link more


I have the same error......... and yes, i have OpenCV library 2.4.5 imported and opened.... but if I write "[...] implements CvViewFrameListener2" in my class I cannot compile because it cause an error

hghg gravatar imagehghg ( 2013-06-24 13:29:48 -0600 )edit

Question Tools


Asked: 2013-05-30 04:53:45 -0600

Seen: 5,154 times

Last updated: Jun 26 '13