Starting from the beginning - problems w/sample code or install ?

asked 2013-05-28 16:31:31 -0500

Howard gravatar image

updated 2013-05-28 18:37:38 -0500

Haveing no luck with Using OpenCV with Eclipse (plugin CDT) for several days

Read on forum that "CV_" as a prefix is no longer used... not sure if this is the problem.

The build went correctly (I think) - ./opencv_test_core works. Only one or two misc. tests failed out of its > 100 or so that were OK.

However, I am unable to get one sample to compile... and I bet I'm not the first person to run into this... sooo....

The example originally suggests getting the installed path via:

pkg-config --cflags opencv

However, that yields only:

$ pkg-config --cflags opencv
Package opencv was not found in the pkg-config search path.
Perhaps you should add the directory containing `opencv.pc'
to the PKG_CONFIG_PATH environment variable
No package 'opencv' found

Huh ? If so, how did Cmake work to make the original build that generated the core test executables ?

Clearly, (I think) it's on the CDT side - I am having problems getting the header files in the correct places. I've tried moving them everywhere (!) including copying them into the project itself, setting the property->include path. ... even just dropped to a shell and command-lined the compile lines complete with includes, but still get unresolved errors - like CV_WINDOW_AUTOSIZE unknown, etc.

Is this because of the header files using relative references, e.g.

opencv2/core/cvstd.hpp

or because of the dropping of "CV_" and somehow I've gotten mixed up versions ? (I got mine from github, not via the tar ball ... and, why should THAT matter ??)

[EDIT] all files I see are opencv-2.4.5, attempting on Fedora

Thanks much for any assistance !

  • HP
edit retag flag offensive close merge delete

Comments

please add some statement, that it's a problem with github master(aka 3.0), not with 2.4.5 (latest stable)

berak gravatar imageberak ( 2013-05-28 16:45:06 -0500 )edit

Thanks for the prompt reply. Hmmm, sorry, I have only a slight clue what you're asking me to do ... I don't know where the problems originate from - or even IF they originate from somewhere else besides me ... thought I'd clearly said so in my OP. EDIT: all files I see are opencv-2.4.5

Howard gravatar imageHoward ( 2013-05-28 16:56:02 -0500 )edit

ok, I'm bailing for now on Fedora... attempting on Mac instead ... :-O I'm just not getting this... weird unresolved items buried deep in the include files... all files except a few, e.g. core_c.h doesn't know what seqInsert is in this block: template<typename _Tp> inline void Seq<_Tp>::insert(int idx, const _Tp& elem) { seqInsert(seq, idx, &elem); }

Howard gravatar imageHoward ( 2013-05-28 20:38:54 -0500 )edit