Ask Your Question
0

Error using Cmake for OpenCV 3.x on Windows with VS2016

asked 2017-03-29 19:45:54 -0500

phoenix gravatar image

Hi, I need OpenCV libraries in 32-bit (I need to use 32-bit dll files elsewhere). When I try to run the CMake gui with 32 bit VS chosen, I get the following error. CMake Error: The following variables are used in this project, but they are set to NOTFOUND. Please set them or make sure they are set and tested correctly in the CMake files: CUDA_cufft_LIBRARY (ADVANCED) and some additional lines.

How do I go about solving this? The solutions I saw online was to compile in 64-bit.. But i need opencv in 32bit.

edit retag flag offensive close merge delete

Comments

afaik, there is nosupport for CUDA and IPP with 32 bits, so you'd have to disable those:

cmake -DWITH_CUDA=OFF -DWITH_IPP=OFF
berak gravatar imageberak ( 2017-03-30 00:38:20 -0500 )edit

Thank you.. it works now

phoenix gravatar imagephoenix ( 2017-04-11 01:05:05 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-03-30 00:38:27 -0500

LBerger gravatar image

VS 2015 or VS 2017?

in cmake_gui uncheck WITH_CUDA and WITH_CUFFT you can disable all cuda module in build too BUILD_opencv_cudaarith, ...

edit flag offensive delete link more

Comments

Thank you.. It works now..

phoenix gravatar imagephoenix ( 2017-04-11 01:04:34 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-03-29 19:45:54 -0500

Seen: 176 times

Last updated: Mar 30 '17