Ask Your Question
0

Error with multiband_blend.cu, compiling Opencv 3.2.0 on Ubuntu 15.10, with CUDA 7.5

asked 2017-02-18 08:37:44 -0500

sisi004 gravatar image

Hello, In my Ubuntu 15.10, with CUDA 7.5, gpu GTX 750 Ti, with opencv and opencv_contrib from git clone, I tried to compile Opencv 3.2.0 many times and after many setttings finally always this error appeared at 74% approximately:

[ 74%] Built target opencv_optflow [ 74%] Generating opencl_kernels_stitching.cpp, opencl_kernels_stitching.hpp [ 74%] Building NVCC (Device) object modules/stitching/CMakeFiles/cuda_compile.dir/src/cuda/./cuda_compile_generated_build_warp_maps.cu.o Scanning dependencies of target opencv_structured_light Linking CXX executable ../../bin/opencv_test_ximgproc [ 74%] Building NVCC (Device) object modules/stitching/CMakeFiles/cuda_compile.dir/src/cuda/./cuda_compile_generated_multiband_blend.cu.o Linking CXX executable ../../bin/opencv_test_aruco [ 74%] Built target opencv_test_aruco [ 74%] Built target opencv_test_ximgproc [ 74%] Building CXX object modules/structured_light/CMakeFiles/opencv_structured_light.dir/src/graycodepattern.cpp.o Scanning dependencies of target opencv_perf_photo /home/elaura/Documentos/App/opencv/modules/stitching/src/cuda/multiband_blend.cu(93): error: Within a __device__/__global__ function, only __shared__ variables may be marked "static"

1 error detected in the compilation of "/tmp/tmpxft_0000270e_00000000-6_multiband_blend.cpp1.ii". CMake Error at cuda_compile_generated_multiband_blend.cu.o.cmake:266 (message): Error generating file /home/elaura/Documentos/App/opencv/release/modules/stitching/CMakeFiles/cuda_compile.dir/src/cuda/./cuda_compile_generated_multiband_blend.cu.o

Scanning dependencies of target opencv_test_photo modules/stitching/CMakeFiles/opencv_stitching.dir/build.make:63: recipe for target 'modules/stitching/CMakeFiles/cuda_compile.dir/src/cuda/./cuda_compile_generated_multiband_blend.cu.o' failed make[2]: * [modules/stitching/CMakeFiles/cuda_compile.dir/src/cuda/./cuda_compile_generated_multiband_blend.cu.o] Error 1 make[2]: *

I was searching possible solutions on the web and nothing, i don't get the relation with compiling opencv.

It seems a problem when it try to generate the multiband_blend function, i need to know why i can't have a Opencv 3.2.0 in my machine. Next the details of the CMakeCache.txt:

VTK support is disabled. Incompatible combination: OpenCV + Qt5 and VTK ver.5.8.0 + Qt4
-- Found VTK ver. 5.8.0 (usefile: /usr/lib/vtk-5.8/UseVTK.cmake)
-- Caffe:   YES
-- Protobuf:   YES
-- Glog:   YES
-- Module opencv_dnn_modern disabled because CMake version is less than 3.2
-- freetype2:   YES
-- harfbuzz:    YES
-- Module opencv_sfm disabled because the following dependencies are not found: Glog/Gflags
-- freetype2:   YES
-- harfbuzz:    YES
-- checking for modules 'tesseract;lept'
--   package 'tesseract' not found
--   package 'lept' not found
-- Tesseract:   NO
-- Caffe:   YES
-- Protobuf:   YES
-- Glog:   YES
-- Check contents of vgg_generated_48.i ...
-- Check contents of vgg_generated_64.i ...
-- Check contents of vgg_generated_80.i ...
-- Check contents of vgg_generated_120.i ...
-- Check contents of boostdesc_bgm.i ...
-- Check contents of boostdesc_bgm_bi.i ...
-- Check contents of boostdesc_bgm_hd.i ...
-- Check contents of boostdesc_binboost_064.i ...
-- Check contents of boostdesc_binboost_128.i ...
-- Check contents of boostdesc_binboost_256.i ...
-- Check contents of boostdesc_lbgm.i ...
-- 
-- General configuration for OpenCV 3.2.0-dev =====================================
--   Version control:               3.2.0-197-g9053839
-- 
--   Extra modules:
--     Location (extra):            /home/elaura/Documentos/App/opencv_contrib/modules
--     Version control (extra):     3.2.0-89-g06752e5
-- 
--   Platform:
--     Timestamp:                   2017-02-18T00:43:08Z
--     Host:                        Linux 3.19.0-69-generic x86_64
--     CMake:                       3.0.2
--     CMake generator:             Unix Makefiles
--     CMake build tool:            /usr/bin/make
--     Configuration:               RELEASE
-- 
--   C/C++:
--     Built as dynamic libs?:      YES
--     C++ Compiler:                /usr/bin/c++  (ver 4.9.2)
--     C++ flags ...
(more)
edit retag flag offensive close merge delete

Comments

Same issue here, the reason of not being able to install. Reported it here.

StevenPuttemans gravatar imageStevenPuttemans ( 2017-02-21 03:20:12 -0500 )edit

I see, thank you.

sisi004 gravatar imagesisi004 ( 2017-02-21 09:17:59 -0500 )edit

I still try to install Opencv3.2, if you could to help i will very thankfully. My other post is titled "Test Files for opencv_contrib/modules/dnn_modern/samples/simple_test.cpp". Thank you.

sisi004 gravatar imagesisi004 ( 2017-02-24 19:04:20 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-02-20 17:38:39 -0500

I had the same problem, Finally i reinstalled opencv3.2 and install opencv3.1. it is not answers what you need, but maybe opencv3.1 is enough for you.

edit flag offensive delete link more

Comments

Yes, i stayed with Opencv 3.1 for now. Thank you for your reply.

sisi004 gravatar imagesisi004 ( 2017-02-21 09:12:34 -0500 )edit

Anyway, i program with deep learning, opencv, dlib and other libraries. I still try to install Opencv3.2, if you could to help i will very thankfully. My other post is titled "Test Files for opencv_contrib/modules/dnn_modern/samples/simple_test.cpp". Thank you.

sisi004 gravatar imagesisi004 ( 2017-02-24 19:03:46 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-02-18 08:37:44 -0500

Seen: 354 times

Last updated: Feb 18 '17