Ask Your Question

install OpneCV with CUDA in MAC

asked 2013-04-29 13:17:17 -0500

nkint gravatar image

Hi! I'm trying to install opencv 2.4.5 on Mac 10.8 with no success. I'm using 2.4.5 opencv because it is the last but If there are some issues on that version i can downgrade, no problem. (I have already installed command line extension from Xcode and CUDA toolkit from NVIDIA)

I'm stucked in setting the right compiler for CUDA.

What I've done is: download opencv, run CMAKE, run make, get the error:

clang: error: unsupported option '-dumpspecs'

(with manual cmake and with macport same error)

So, after some google i've found that the problem could be CUDA_HOST_COMPILER. I've tried to change it in /usr/bin/gcc, /usr/bin/llvm-g++ and i get on but after a little while I get another error:

cc1plus: error: unrecognized command line option "-Wno-narrowing"

I can post all output from cmake and make, if it needed.

What can I do? I need to compile opencv with cuda, but I don't have other need like a particular version of opencv or gcc or clang or llvm (and I normally develop under ubuntu so I don't understand deeply the differences between those compilers).

this is my system settings:

OS X 10.8.3 (12D78)


>>> clang --version
Apple LLVM version 4.2 (clang-425.0.24) (based on LLVM 3.2svn)
Target: x86_64-apple-darwin12.3.0
Thread model: posix


>>> g++ --version
i686-apple-darwin11-llvm-g++-4.2 (GCC) 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.11.00)
>>> ls -al /usr/bin/g++
/usr/bin/g++ -> llvm-g++-4.2


>>> cc --version
Apple LLVM version 4.2 (clang-425.0.24) (based on LLVM 3.2svn)
Target: x86_64-apple-darwin12.3.0
Thread model: posix
>>> ls -al /usr/bin/cc
/usr/bin/cc -> clang
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2013-05-21 14:18:25 -0500

cgarnier gravatar image

Hi, I have the same problem as you on my OS X 10.8.3 with OpenCV 2.4.5.
I have the latest updates for compilers (from Xcode) and I installed the CUDA driver as well as the CUDA Toolkit 5.0.

I tried Cmake and Homebrew (modifying the formula). But I still have the same error as you when compiling with CUDA support.

Did you find a solution to compile OpenCV with CUDA ?

edit flag offensive delete link more


no. it is very annoying because i have done an application under ubuntu that use gpu stuff a lot. but i can't run on my mac. i hope to find a solution.. just in case, keep in touch

nkint gravatar imagenkint ( 2013-05-27 04:02:25 -0500 )edit

Question Tools

1 follower


Asked: 2013-04-29 13:17:17 -0500

Seen: 859 times

Last updated: May 21 '13