Memory error during calibration of IR camera

asked 2017-02-01 10:31:17 -0500

TPS gravatar image

Hello,

I'm trying to calibrate my IR camera (Optitrack NaturalPoint) using the camera calibration module of OpenCV 3.0.0 and Visual Studio 2015. I used an assymetrical circle grid. I'm using screenshots of the display of the camera. When I run it, I get an memory problem ("Exception thrown at ...") but when I run it with the images given in openCV, the probleme executes cithout errors. So I wonder if one of you have ever experienced the same issue ? Do you have a solution to calibrate IR cameras ?

Thank you in advance

edit retag flag offensive close merge delete

Comments

Screenshots of the display? Not a happy way of doing it. Much better to load the images directly into memory.

Are they all the same size? It's possible you cropped them not quite the same.

Tetragramm gravatar imageTetragramm ( 2017-02-01 17:44:37 -0500 )edit

Thanks for your reply. I'm not sure to understand what you mean by saying "load the images directy into memory"? Because I did screenshots, then saved them as images that I put in the configuration file. The images where actually not the same size but I fixed it after I read your comment and it still did'nt work.

TPS gravatar imageTPS ( 2017-02-03 09:15:16 -0500 )edit

It's a USB camera, yes? You can open it with the standard OpenCV VideoCapture and save the images with imwrite. Taking screenshots is an almost sure way to screw up.

Even better, you can use the interactive camera calibration application that comes with OpenCV. Read the tutorial and it should help you avoid problems.

Tetragramm gravatar imageTetragramm ( 2017-02-03 21:24:51 -0500 )edit