Can't build opencv 2.4.11 with python

asked 2016-12-28 12:29:26 -0500

kevgeo gravatar image

When I try to build opencv 2.4.11 with both c++ and python, an error comes up for python-

Traceback (most recent call last):
File "<string>", line 1, in <module>
ImportError: No module named numpy.distutils

The thing is numpy is installed for python 2.7.6 and not for python 2.7.9 which is what opencv is trying to build from.

How do I rectify this issue? How can I make opencv build particularly with python 2.7.6 or install numpy with python 2.7.9?

edit retag flag offensive close merge delete

Comments

try to update numpy to a more recent version

berak gravatar imageberak ( 2016-12-29 08:20:53 -0500 )edit