Ask Your Question
0

VideoCapture problem in opencv 2.4.11, Ubuntu 14.04, eclipse mars [closed]

asked 2016-11-21 08:45:48 -0500

marcin gravatar image

updated 2016-11-21 08:46:37 -0500

Hi,

I downloaded opencv 2.4.11 and the linker can not find some functions (VideoCapture, namedWindow, ...): /test/gstreamer2opencv/Debug/../gstreamer2opencv.cpp:160: undefined reference to `cv::VideoCapture::VideoCapture(cv::String const&)'

/test/gstreamer2opencv/Debug/../gstreamer2opencv.cpp:167: undefined reference to `cv::namedWindow(cv::String const&, int)'

/test/gstreamer2opencv/Debug/../gstreamer2opencv.cpp:171: undefined reference to `cv::VideoCapture::read(cv::_OutputArray const&)'

/test/gstreamer2opencv/Debug/../gstreamer2opencv.cpp:174: undefined reference to `cv::imshow(cv::String const&, cv::_InputArray const&)'

I am linking core and highgui libs. grep finds lines with those functions in libhighgui.so, so I do not understand what is going on. If I remove highgui lib I get even more reference errors, so my paths seem to be correct, too. Anyone have an idea what could be the problem?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by marcin
close date 2016-11-22 01:20:16.830916

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-11-22 01:21:50 -0500

marcin gravatar image

updated 2016-11-22 02:53:20 -0500

berak gravatar image

I removed 2.4.11 and installed 2.4.8 from synaptic, now everything works fine.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-11-21 08:45:48 -0500

Seen: 111 times

Last updated: Nov 22 '16