I got error when i run make command in fedora 18

asked 2013-04-10 12:24:42 -0500

sabi gravatar image

updated 2013-04-10 13:34:33 -0500

Hi, when I tried to install openCV 2.4.4 in Fedora 18 (http://fedoraproject.org/)

I got the following error:

Linking CXX executable ../../bin/opencv_perf_core
/lib/libEGL.so.1: undefined reference to `wl_display_dispatch_queue_pending'
collect2: error: ld returned 1 exit status
make[2]: *** [bin/opencv_perf_core] Error 1
make[1]: *** [modules/core/CMakeFiles/opencv_perf_core.dir/all] Error 2
make: *** [all] Error 2

I used the following command:

[cmake -D CMAKE_BUILD_TYPRE=RELEASE -D CMAKE_INSTALL_PREFIRX=/usr ..]

And I have done

yum install gcc-c++ ffmpeg ffmpeg-devel gtk2-devel git pkgconfig

and all of this packages installed correctly in my fedora 18

after that i got opencv source 2.4.4 from this homepage

and when i run make command I got above error message when it 33% done.

I have no idea how to i solve this problem. Please someone let me know what should i do ? Are there any other packages i should install more?

Please let me know

[i tried to install libavcodec-dev, libavformat-dev, libswscale-dev but yum install dose not work with it no package found error occur]

edit retag flag offensive close merge delete