opencv_xx.jar not found [closed]

asked 2016-11-08 14:51:36 -0500

aliyesami gravatar image

I successfully installed and compiled the opencv on centos using the following method but I cant find any opencv_xxx.jar files anywhere ? that's why I think when I run the DetectFaceDemo.java program I get error "package org.opencv.core does not exist" and I have defined JAVA_HOME to a valid jdk environment before the cmake and make steps.

1.install all the required packages using yum

yum groupinstall "Development Tools"

yum install gcc

yum install cmake

yum install git

yum install gtk2-devel

yum install pkgconfig

yum install numpy

yum install ffmpeg

2.Create working directory and check out the source code

mkdir /opt/working

cd /opt/working

git clone https://github.com/Itseez/opencv.git

cd opencv

git checkout tags/2.4.8.2

3.Create the Makefile

mkdir release

cd release

cmake -D CMAKE_BUILD_TYPE=RELEASE -D CMAKE_INSTALL_PREFIX=/usr/local ..

4.Build and install

cd /opt/working/opencv/release

make

make install

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by berak
close date 2016-11-09 08:47:33.776412

Comments

have a look here , it seems to be missing.ant

can we see your cmake output ?

berak gravatar imageberak ( 2016-11-08 18:46:41 -0500 )edit

Thanks Berak that exactly was the cause . It compiled and created the opencv jar . I am not seeing how I can mark your comment as "ANSWER" so you can add it as answer.

aliyesami gravatar imagealiyesami ( 2016-11-09 08:36:44 -0500 )edit

let's just call it solved as it is.

berak gravatar imageberak ( 2016-11-09 08:48:10 -0500 )edit