Ask Your Question
0

No communication between OpenCV and FlyCapture (Point Grey) in Linux 14.04

asked 2016-09-15 06:35:23 -0500

Ludo gravatar image

updated 2016-09-15 06:42:17 -0500

I am trying to use ArUco program (http://www.uco.es/investiga/grupos/av...) with a PontGrey Grasshopper 3. (USB 3.0). The problem is that when I run the program 'cpp-example-calibration' from OpenCV to create the file 'camera.yml' (http://maztories.blogspot.nl/2013/07/...) I get the error: Could not initialize video (0) capture

As I understand, there is no communication between OpenCV and the camera. For this reason I tried to use the examples for Windows given in the bottom of the page https://www.ptgrey.com/KB/10861 (where it says 'These examples') without success due to the errors:

  • han@han-H81M-S2H:~/Desktop/FlyCap-OpenCV_samples/FlyCap2_to_MatImage$g++ FlyCap2_to_MatImage.cpp
  • /tmp/ccPj46ef.o: In function `main':
  • FlyCap2_to_MatImage.cpp:(.text+0x2a): undefined reference to `FlyCapture2::Error::Error()'
  • FlyCap2_to_MatImage.cpp:(.text+0x39): undefined reference to `FlyCapture2::Camera::Camera()'
  • ...
  • FlyCap2_to_MatImage.cpp:(.text._ZN2cv3Mat7releaseEv[_ZN2cv3Mat7releaseEv]+0x47): undefined reference to `cv::Mat::deallocate()'
  • collect2: error: ld returned 1 exit status

The same PointGrey webpage mentions that 'OpenCV does not support machine vision standards such as USB3 Vision and GigE Vision'. and the Support Assistant wrote me in a mail: 'we wouldn't be able to provide support for using our cameras with opencv on Linux.'.

What can I do to solve this problem? Do you know how to solve this? please Help :)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-09-15 14:11:26 -0500

pklab gravatar image

Camera interfaces doesn't matter. Really you can't use VideoCapture to grab from some USB3 Vision and GigE Vision cameras

But You have to get the frame from PointGrey library into a memory buffer than you have to declare a cv::Mat over "user allocated data" adjusting memory layout if it's needed.

Of course you have to include and link the PointGrey library into your OpenCV project

edit flag offensive delete link more

Comments

Thank you. But when I include the libraries and use the classes for FlyCapture and cv i get the same errors of "Undefined reference to..."

Ludo gravatar imageLudo ( 2016-09-20 06:18:49 -0500 )edit

This isn't an OpenCV issue, search the Net for "Undefined reference to" ... simply you have to configure your project to include .h files AND LINK static .a or dynamic .o files from OpenCV and PointGrey's library

pklab gravatar imagepklab ( 2016-09-21 02:43:00 -0500 )edit

Thank you. I will look for the way to do it.

Ludo gravatar imageLudo ( 2016-09-21 10:14:57 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-09-15 06:35:23 -0500

Seen: 1,142 times

Last updated: Sep 15 '16