Ask Your Question
1

opencv-3.1.0 compile with contrib error when compile aruco

asked 2016-08-27 21:07:10 -0500

hzw gravatar image

...../opencv_contrib/modules/aruco/src/charuco.cpp: In function ‘double cv::aruco::calibrateCameraCharuco(cv::InputArrayOfArrays, cv::InputArrayOfArrays, cv::Ptr<cv::aruco::charucoboard>&, cv::Size, cv::InputOutputArray, cv::InputOutputArray, cv::OutputArrayOfArrays, cv::OutputArrayOfArrays, cv::OutputArray, cv::OutputArray, cv::OutputArray, int, cv::TermCriteria)’:

..../opencv_contrib/modules/aruco/src/charuco.cpp:741:59: error: cannot convert ‘const cv::_OutputArray’ to ‘int’ for argument ‘8’ to ‘double cv::calibrateCamera(cv::InputArrayOfArrays, cv::InputArrayOfArrays, cv::Size, cv::InputOutputArray, cv::InputOutputArray, cv::OutputArrayOfArrays, cv::OutputArrayOfArrays, int, cv::TermCriteria)’ _perViewErrors, flags, criteria); ^

edit retag flag offensive close merge delete

Comments

1

did you update this from a previous 3.1 version ? if so, try to clean the build folder, and rerun cmake && make && make install (i'm just guessing, a stale pch file got in your way)

berak gravatar imageberak ( 2016-08-28 01:35:48 -0500 )edit

I get the feeling that you are this guy and thus can you provide the output I asked for in that topic?

StevenPuttemans gravatar imageStevenPuttemans ( 2016-08-29 04:52:04 -0500 )edit

thanks a lot, I got the opencv-3.1.0 source from the download page not the github, but the contrib is from the github, I'll try to get just from github.@berak@StevenPuttemans

hzw gravatar imagehzw ( 2016-08-29 04:59:35 -0500 )edit

@hzw, as said before, that will not work :) you will need github compatible branches :)

StevenPuttemans gravatar imageStevenPuttemans ( 2016-08-29 07:06:24 -0500 )edit

Can you give me the links where to download and retry, I am getting the same error as this person. I followed this procedure >http://embedonix.com/articles/image-processing/installing-opencv-3-1-0-on-ubuntu/

sachitmahajan gravatar imagesachitmahajan ( 2016-08-29 08:20:53 -0500 )edit

and the biggerst issue is that i need opencv for ARTag detection, hence i need the aruco contib

sachitmahajan gravatar imagesachitmahajan ( 2016-08-29 08:25:34 -0500 )edit

Go to your command line

Then you have latest versions!

StevenPuttemans gravatar imageStevenPuttemans ( 2016-08-29 08:37:39 -0500 )edit

I think the error occurs due to updates made in the aruco and charuco file, 3-4 days ago. I ll try what you suggested.

sachitmahajan gravatar imagesachitmahajan ( 2016-08-29 08:45:37 -0500 )edit

Already on 'master' Your branch is up-to-date with 'origin/master'.

sachitmahajan gravatar imagesachitmahajan ( 2016-08-29 08:47:16 -0500 )edit

If you don't use Aruco, just make it OFF in cmake, compile other module is fine

hzw gravatar imagehzw ( 2016-08-29 09:52:46 -0500 )edit

1 answer

Sort by » oldest newest most voted
-2

answered 2016-08-29 09:29:50 -0500

sachitmahajan gravatar image

updated 2016-08-29 09:30:35 -0500

This worked for me Delete Aruco from /opencv_contrib/modules use

pkg-config --modversion opencv

to confirm opencv 3.1.0 Seperately download aruco from soundforge if you need.

edit flag offensive delete link more

Comments

waait. the aruco lib on SF is not opencv's aruco module. (and opencv's aruco module is not available on SF.)

so, your answer does not solve the original problem.

berak gravatar imageberak ( 2016-08-29 09:47:42 -0500 )edit

I just gave an alternate that completes the installation of opencv, I asked him to download aruco separately. for now if he needs as the one currently present is hindering the installation process

sachitmahajan gravatar imagesachitmahajan ( 2016-08-29 13:10:18 -0500 )edit

That is like hey I got no money, so I just rob a bank and get the money, and then say that I did not perform a crime ...

StevenPuttemans gravatar imageStevenPuttemans ( 2016-08-30 03:11:14 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-08-27 21:07:10 -0500

Seen: 3,036 times

Last updated: Oct 07 '16