Ask Your Question
0

PR Curve for Cascade w/ detectMultiScale3: Never Completes

asked 2016-08-20 12:02:20 -0500

I have a custom trained cascade and using detectMultiScale I am able to sweep over my test set (128 images) for the best performing scale and neighborhood parameters in a minute or two. I am getting a decent results, but what I'd like to do is generate a PR curve for the cascade and for that I need a threshold or confidence value. I did a little reading/searching that suggested using OpenCV 3.1.0 and detectMultiScale3 with outputRejectLevels=True which would provide me with some weights (or confidence levels) that could be used for this purpose; however, when I updated my version of OpenCV, the function call, and tried to run the classifier on a single image to compare the results... the classifier never seems to finish running even after 10 minutes or so. I should also mention that I am running Python 2.7, Windows 7, with the x86 version of OpenCV 3.1.0. My questions are:

Is this a known issue? Might there be another option for generating a PR Curve for cascades? I suppose I could alter the neighborhood and scale parameters, but I am not accustom to doing this for generating PR curves.

edit retag flag offensive close merge delete

Comments

This is strange. My detection models are working just fine on the latest master branch in my case. BTW, I am using 2 things for precision recall. The first one could be the number of overlapping detections that are merged together. The second one is indeed retrieving that score. However, the problem with that and the previous is that somehow OpenCV is not only returning detections from the last stage but from the 4 last stages ... still not a clue why they really do that.

StevenPuttemans gravatar imageStevenPuttemans ( 2016-08-23 08:13:47 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-08-20 13:02:54 -0500

I ended up downgrading to OpenCV 3.0.0 and the code worked without any changes; it would appear that detectMultiScale3 is not working in OpenCV 3.1.0. If anyone else is encountering this issue and isn't using anything specific to 3.1.0 then this work around may work for you as well!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-08-20 12:00:32 -0500

Seen: 221 times

Last updated: Aug 20 '16