Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I can help a little bit, but I don't have all the answers.

The reason you were getting the "Failed to load openh264 library" error is because you didn't have it added to the environment. You go to Control Panel->System and Security->System On the left side is Advanced System Settings. Then click on Environment Variables, and in the System Variables section, add OPENH264_LIBRARY_PATH with a value of the location of the .dll

The rest is an option in the OpenCV_ffmpeg module that comes with OpenCV. Unfortunately, it only comes pre-compiled, and you can't get to wherever it sets the option.

I do hope some future version fixes this, since I would like to be able to control the bit-rate too.