Ask Your Question

Revision history [back]

Hi Zindarod,

this answer is probably too late for you, but I ran across this post was on my search for solution to the same problem.

The trick is to pass the -protocol_whitelist=file,rtp,udp to FFMPEG, which you can achieve through python and OpenCV by setting the following environment variable: os.environ['OPENCV_FFMPEG_CAPTURE_OPTIONS'] = 'protocol_whitelist;file,rtp,udp'

Best Regards,

Stian Solbø