Ask Your Question

Revision history [back]

The reason why single rectangle is created at the center is because the detector classified almost all region as "human". By default, detectMultiScale suppress the overlap of the rectangles. So you can only see the single rectangle at the center. This suppression can be turned off with finalThreshold option of detectMultiScale.

bb,w = hog.detectMultiScale(img, winStride=(8,8), padding=(32,32), scale =1.05, finalThreshold=0)

You can see almost all regions are filled by the rectangle color.

Now, please try the followings.

  • svm kernel type set to linear
  • change the sign of rho
  • change the training index (positive: 0, negative: 1)