Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Imread without exif title results in invalid Mat

Hi,

I wonder whether this is a bug or not: Im trying to load this image:

not_working_image

using

Mat A = cv::imread(path, CV_LOAD_IMAGE_ANYDEPTH);

But it results in a invalid Mat. If I put it to my watchlist, it says it got zero rows. Since google wasn't able to tell me how to fix this problem, I tried investigating this problem by myself. Somehow it fixes the problem when I give the file an exif title (rightclick -> details -> title):

working_image

This is exactly the same image, just with a title in the details.

The image was created by/obtained with PFV which is a high-speed camera software.

Thanks for your help!

Imread without exif title results in invalid Mat

Hi,

I wonder whether this is a bug or not: Im trying to load this image:

not_working_image

using

Mat A = cv::imread(path, CV_LOAD_IMAGE_ANYDEPTH);

But it results in a invalid Mat. If I put it to my watchlist, it says it got zero rows. Since google wasn't able to tell me how to fix this problem, I tried investigating this problem by myself. Somehow it fixes the problem when I give the file an exif title (rightclick -> details -> title):

working_image

This is exactly the same image, just with a title in the details.

The image was created by/obtained with PFV which is a high-speed camera software.

Thanks for your help!

Edit: Uploading image does not work?!

Imread without exif title results in invalid Mat

Hi,

I wonder whether this is a bug or not: Im trying to load this image:

not_working_image

using image1

Mat A = cv::imread(path, CV_LOAD_IMAGE_ANYDEPTH);

But it results in a invalid Mat. If I put it to my watchlist, it says it got zero rows. Since google wasn't able to tell me how to fix this problem, I tried investigating this problem by myself. Somehow it fixes the problem when I give the file an exif title (rightclick -> details -> title):

working_image image2

This is exactly the same image, just with a title in the details.

The image was created by/obtained with PFV which is a high-speed camera software.

Thanks for your help!

Edit: Uploading image does not work?!

Imread without exif title results in invalid Mat

Hi,

I wonder whether this is a bug or not: not:

Im trying to load this image:

not_working_image image1

Mat A = cv::imread(path, CV_LOAD_IMAGE_ANYDEPTH);

But it results in a invalid Mat. If I put it to my watchlist, it says it got zero rows. Since google wasn't able to tell me how to fix this problem, I tried investigating this problem by myself. Somehow it fixes the problem when I give the file an exif title (rightclick -> details -> title):

working_image image2

This is exactly the same image, just with a title in the details.

The image was created by/obtained with PFV which is a high-speed camera software.

Since I dont want to manually edit all files, a solution for this problem would be nice.

Thanks for your help!

Edit: Uploading image does not work?!