Ask Your Question

Having problem in accessing ..jni/include directory

asked 2013-03-16 09:14:41 -0500

anupdeo gravatar image

updated 2013-03-16 12:31:51 -0500

Alexander Smorkalov gravatar image

Hi Guys, I am having the following error in my Face Recognition project which is developed in android using OpenCV.

****16:01:59 **** Auto Build of configuration Default for project Face Recognition ****
jni/ F:/OpenCVWorkSpace/OpenCV-2.4.4-android-sdk/sdk/native/jni/include: Permission denied
"Compile++ thumb : native_sample <= jni_part.cpp
jni/jni_part.cpp:2:33: fatal error: opencv2/core/core.hpp: No such file or directory
compilation terminated.
make: *** [obj/local/armeabi/objs/native_sample/jni_part.o] Error 1****

I don't know what's going wrong. I have followed all the documentation which is given on But it's not working. I'm a beginner in android. please suggest solutions if any....

edit retag flag offensive close merge delete


as u said I changed the Ower of OpenCV4Android SDK folder. I also add acces to the OpenCV4Android SDK folder for current user but still it is giving the same error.....

anupdeo gravatar imageanupdeo ( 2013-03-18 06:19:26 -0500 )edit

I have the same error... did you solve it?

Lawra gravatar imageLawra ( 2013-04-10 13:47:06 -0500 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2013-03-16 12:40:16 -0500

Alexander Smorkalov gravatar image

You need to change owner of OpenCV4Android SDK folder recursively or add access to it for your user. Both operations you can make in folder properties.

edit flag offensive delete link more

answered 2013-06-19 05:51:05 -0500

OpenCVed gravatar image

image description


problem is not solving in jni_part.cpp for face detection android app

edit flag offensive delete link more


pLease solve this

OpenCVed gravatar imageOpenCVed ( 2013-06-19 05:52:57 -0500 )edit
Login/Signup to Answer

Question Tools


Asked: 2013-03-16 09:14:41 -0500

Seen: 571 times

Last updated: Jun 19 '13