Ask Your Question
0

Issues with cv 2.4.4 opencv_core244d.dll and VS2012

asked 2013-03-06 16:00:04 -0500

Irish gravatar image

updated 2013-03-06 16:10:20 -0500

I'm fairly new to opencv, and really by that I mean that I haven't used it at all yet, but would like to. Currently when I run a simple program like, just initializing an image object like: "Mat test;" and attempt to run it, it crashes in debug mode, but not release.

"program can't start because opencv_core244d.dll is missing from your computer."

With someone's help I was able to set up OpenCV_Debug and OpenCV_Release within the VS property manager with seemingly all the correct paths and lib that I may need. I also set up the system path to include C:\opencv\build\x86\vc11\bin, but still when I attempt to run a program in debug mode, it crashes with the error.

Any thoughts/suggestions would be greatly appreciated.

on a side note, it works fine if I just throw the necisarry .dll files in the project folder, I was just hoping to solve this minor issue.

Thanks!

edit: forgot to add in the actual error

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2013-03-06 16:21:17 -0500

berak gravatar image

updated 2013-03-06 16:25:07 -0500

sounds like you just copied the library list from release to the debug settings.

just note, that running a release exe with debug dlls will crash the same way as running a debug exe trying to load release dlls

so, for debug, take a look at the actual lib folder, note they all got a 'd' at the end, adjust your 'Additional Libraries' settings to point to the 'debug' version, and finally, edit that library list, so it's all like

'opencv_core244d.lib'

yes, 'd' at the end, all the way down !

oh, took a 2nd read at your post, maybe another thing you're lacking is another entry in your PATH environment var, pointing to the folder with the debug dlls ( for the runtime ) as well

edit flag offensive delete link more

Comments

+1 for forgetting the actual error ;)

berak gravatar imageberak ( 2013-03-06 16:26:14 -0500 )edit

I actually copied it the other way around, strange right? I copied the debug and just took off the 'd's. For the additional libraries I currently have it set to: "c:/opencv/build/x86/vc11/lib;%(AdditionalLibraryDirectories)" is this correct? Thanks for the reply btw!

Irish gravatar imageIrish ( 2013-03-06 16:52:16 -0500 )edit
2

oh, the lib folder (for the prebuild libs) actually contains both release and debug versions, i was wrong at guessing, if you're using prebuild/self compiled version there, also your AdditionalLibraryDirectories is correct in the prebuild case.

if it's "program can't start because opencv_core244d.dll is missing from your computer", that's a problem at runtime, not when compiling. it just can't find the dll ;)

check your PATH variable again, and append ";c:/opencv/build/x86/vc11/bin" if nessecary

berak gravatar imageberak ( 2013-03-06 17:17:56 -0500 )edit

I changed x86 to x64, and it seems to subsided the error. Not quite sure why it worked, but I'm happy that it did. Thanks for the help!

Irish gravatar imageIrish ( 2013-03-07 01:30:59 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2013-03-06 16:00:04 -0500

Seen: 1,268 times

Last updated: Mar 06 '13