No accelerated colorspace conversion found from yuv422p to rgb24

asked 2012-12-19 13:33:32 -0500

dinamex gravatar image

Hi all,

I would like to use the hardware enabled mjpeg compression of my webcam (Logitech c920). I'm using a Pandaboard (ARM) and ubuntu 11.10 Server. I use as camera driver the ROS usb_cam package which works with YUYV but when I change the pixelformat to MJPEG I'll get following warning.

[swscaler @ 0xe8d640] No accelerated colorspace conversion found from yuv422p to rgb24.

The camera works but has a big time difference between the output and the actual image (about 2-3 seconds). According to some googling this warning leads to some lag and is caused by some old dependencies. Therefore I installed ffmpeg-0.10.6, ffmpeg-0.6.2 & ffmpeg-0.6.6 all with the same result. I always rebuild OpenCV afterward. Is it a ffmpeg problem or is that caused by OpenCV?

This is my cmake configuration of OpenCV 2.3.1:
BUILD_DOCS ON
BUILD_EXAMPLES OFF
BUILD_NEW_PYTHON_SUPPORT ON
BUILD_PACKAGE ON
BUILD_SHARED_LIBS ON
BUILD_TESTS OFF
BUILD_WITH_DEBUG_INFO ON
BZIP2_LIBRARIES /usr/lib/libbz2.so
CMAKE_BACKWARDS_COMPATIBILITY 2.4
CMAKE_BUILD_TYPE RELEASE
CMAKE_CONFIGURATION_TYPES Debug;Release
CMAKE_INSTALL_PREFIX /usr/local
CMAKE_VERBOSE OFF
CUDA_BUILD_CUBIN OFF
CUDA_BUILD_EMULATION OFF
CUDA_SDK_ROOT_DIR CUDA_SDK_ROOT_DIR-NOTFOUND
CUDA_TOOLKIT_ROOT_DIR CUDA_TOOLKIT_ROOT_DIR-NOTFOUND
CUDA_VERBOSE_BUILD OFF
EIGEN_INCLUDE_PATH /usr/include/eigen3
ENABLE_PROFILING OFF
ENABLE_SOLUTION_FOLDERS OFF
EXECUTABLE_OUTPUT_PATH /home/panda/ros_workspace/OpenCV-2.3.1/release/bin
INSTALL_C_EXAMPLES OFF
INSTALL_PYTHON_EXAMPLES OFF
LIBRARY_OUTPUT_PATH /home/panda/ros_workspace/OpenCV-2.3.1/release/lib
OPENCV_BUILD_3RDPARTY_LIBS OFF
OPENCV_CONFIG_FILE_INCLUDE_DIR /home/panda/ros_workspace/OpenCV-2.3.1/release
OPENCV_EXTRA_C_FLAGS
OPENCV_EXTRA_C_FLAGS_DEBUG
OPENCV_EXTRA_C_FLAGS_RELEASE
OPENCV_EXTRA_EXE_LINKER_FLAGS
OPENCV_EXTRA_EXE_LINKER_FLAGS_
OPENCV_EXTRA_EXE_LINKER_FLAGS_
OPENCV_MANGLED_INSTALL_PATHS OFF
OPENCV_WARNINGS_ARE_ERRORS OFF
OPENEXR_INCLUDE_PATH OPENEXR_INCLUDE_PATH-NOTFOUND
OPENNI_INCLUDE_DIR /usr/include/ni
OPENNI_LIB_DIR /usr/lib
OPENNI_PRIME_SENSOR_MODULE_BIN /usr/lib
PVAPI_INCLUDE_PATH PVAPI_INCLUDE_PATH-NOTFOUND
PYTHON_PACKAGES_PATH lib/python2.7/dist-packages
USE_OMIT_FRAME_POINTER ON
USE_PRECOMPILED_HEADERS ON
WITH_1394 OFF
WITH_CUDA OFF
WITH_EIGEN ON
WITH_FFMPEG ON
WITH_GSTREAMER ON
WITH_GTK ON
WITH_IPP OFF
WITH_JASPER ON
WITH_JPEG ON
WITH_OPENEXR ON
WITH_OPENNI ON
WITH_PNG ON
WITH_PVAPI ON
WITH_QT OFF
WITH_QT_OPENGL OFF
WITH_TBB OFF
WITH_TIFF ON
WITH_UNICAP ON
WITH_V4L ON
WITH_XIMEA OFF
WITH_XINE OFF

my configuration options to install ffmpeg:
H.264 (git clone --depth 1 git://git.videolan.org/x264)
./configure --enable-static --enable-pic --enable-shared
make
sudo checkinstall --pkgname=libx264-dev --pkgversion="3:$(./version.sh | awk -F'[" ]' '/POINT/{print $4"+git"$5}')" --backup=no --deldoc=yes --fstrans=no --default

AAC audio encoder (git clone --depth 1 git://github.com/mstorsjo/fdk-aac.git)
autoreconf -fiv
./configure --enable-pic --enable-shared
make
sudo checkinstall --pkgname=fdk-aac --pkgversion="$(date +%Y%m%d%H%M)-git" --backup=no --deldoc=yes --fstrans=no --default

libvpx (git clone --depth 1 http://git.chromium.org/webm/libvpx.git)
./configure --enable-pic
make
sudo checkinstall --pkgname=libvpx --pkgversion="1:$(date +%Y%m%d%H%M)-git" --backup=no --deldoc=yes --fstrans=no --default

FFmpeg (git clone --depth 1 git://source.ffmpeg.org/ffmpeg)
./configure --enable-gpl --enable-version3 --enable-nonfree --enable-libvpx --enable-postproc --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis --enable-libx264 --enable-shared --enable-swscale --enable-pic
make
sudo checkinstall --pkgname=ffmpeg --pkgversion="7:$(date +%Y%m%d%H%M)-git" --backup=no --deldoc=yes --fstrans=no --default
hash x264 ffmpeg ffplay ffprobe

edit retag flag offensive close merge delete