Ask Your Question
2

openCV 2.4.3 iOS background_segm.hpp 'list' file not found

asked 2012-12-15 14:00:32 -0500

washe gravatar image

updated 2012-12-15 18:09:43 -0500

I'm having lots of fun attempting to get openCV up and running with iOS 5,6 / xcode 4.5.2 / osx 10.8.2...

i was attempting to build the OSX framework as per these instructions (section 2, "use CMake to build"), but

make -j8

was failing with

CMake Error: Parse error in cache file build/CMakeCache.txt.   
Offending entry: /SDKs/MacOSX10.8.sdk

(CMake v2.8.2, maybe I needed a more recent version?)

Anyway I have since made better progress with the iPhone framework by using the prebuilt 2.4.3 framework on the site. However I am getting the following build error in Xcode:

#include <list>       !'list' file not found

In any framework file that attempts to #include <list>

Is this a search path issue? Something else?

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
1

answered 2013-03-18 17:33:15 -0500

Yun gravatar image

I have the same setup, and same problem. and I just changed the file ext from .m to .mm, it works for me. Good luck

edit flag offensive delete link more
1

answered 2012-12-19 07:54:08 -0500

I kinda sorta figured it out - 1) change your .m project files to .mm 2) add libc++.dylib to 'Linked Frameworks and Libraries'

edit flag offensive delete link more

Comments

thanks, I resolve the issue as you said.

Vale1988 gravatar imageVale1988 ( 2014-08-23 02:14:18 -0500 )edit
-1

answered 2012-12-19 04:13:19 -0500

Hi,

I was trying to tackle this problem but so far no luck. Got any progress from your side?

~xac

edit flag offensive delete link more

Comments

Downvoted. Not an answer.

Tõnu Samuel gravatar imageTõnu Samuel ( 2016-09-11 19:43:47 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2012-12-15 14:00:32 -0500

Seen: 8,372 times

Last updated: Mar 18 '13