Ask Your Question
0

The app was unable to start correctly (0xc000007b)

asked 2014-11-07 16:19:21 -0500

alexjr1984 gravatar image

Hello,

I've encountered the mentioned error while trying to execute my program, which, for simplicity sake only has a main and a single line:

cv::Mat mainPic_ = imread("path");

I searched about it and I know that it's a 64bit and 32bit dll mismatch. I haven't been able to find out exactly where however.

My OP is WIN7 64bit. I'm using VS 2010 in win32 debug mode.

opencv-2.4.9

c\c++ general: "c:\opencv\build\include\"

linker general: "c:\opencv\build\x86\vc10\lib

PATH: "c:\opencv\build\x86\vc10\bin\"

Result of Dependency Walker:

Module:

API-MS-WIN-APPMODEL-RUNTIME-L1-1-0.DLL

API-MS-WIN-CORE-WINRT-ERROR-L1-1-0.DLL

API-MS-WIN-CORE-WINRT-L1-1-0.DLL

API-MS-WIN-CORE-WINRT-ROBUFFER-L1-1-0.DLL

API-MS-WIN-CORE-WINRT-STRING-L1-1-0.DLL

API-MS-WIN-SHCORE-SCALING-L1-1-0.DLL

DCOMP.DLL, GPSVC.DLL, IESHIMS.DLL, VCOMP90.DLL

Warning: At least one delay-load dependency module was not found.

Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

All of the mentioned DLL above are in system32. I also tried uninstall and reinstall Microsoft Visual C++ 2010 Redistributable Package (x86). Didn't help.

Any ideas?

Thanks,

Alex

edit retag flag offensive close merge delete

Comments

Hi there,

I have exactly the same problem using Visual studio 2013 and opencv-2.4.13. Yesterday everything worked fine, this morning I started Visual studio and I get this error. Is there someone who knows what to do with it?

Michael Gotsch gravatar imageMichael Gotsch ( 2016-07-06 12:28:40 -0500 )edit

Did you change project properties?

unxnut gravatar imageunxnut ( 2016-07-06 16:29:25 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2017-09-14 06:34:14 -0500

0xc000007b is a very common error. Have you tried running the program as an administrator. If not, then try it this way. For this purpose, just right click on the application and select Run as administrative from the list. Click Yes when a new windows pops-up and you will find the application running smoothly. Hopefully, this will solve your problem.

edit flag offensive delete link more
0

answered 2014-11-07 17:28:28 -0500

unxnut gravatar image

Make sure that OpenCV is compiled as 32-bit as well. Otherwise, you can try to compile the app as 64-bit and see if that helps.

edit flag offensive delete link more

Comments

Are there any specific changes I need to make in VS to make it compile as 32-bit? As for the 64-bit compiling, there is a different lib I'm gonna have to use in the future that is a 32 bit process and won't work as a 64.

alexjr1984 gravatar imagealexjr1984 ( 2014-11-08 02:49:01 -0500 )edit

You should be able to change it in project properties. It is a dropdown menu option.

unxnut gravatar imageunxnut ( 2014-11-08 07:36:32 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2014-11-07 16:19:21 -0500

Seen: 4,476 times

Last updated: Jul 10