Problem for build opencv libraries with CMkake

asked 2014-07-03 04:55:20 -0500

Jesus gravatar image

updated 2014-07-03 04:57:28 -0500

berak gravatar image

Hi guys I am not an expert I have an problem with the cross-compilation of opencv for ARM.

My problem is that when I build the libraries with the Cmake it finish propertly but this is the output:

GUI: 
--     QT 4.x:                      NO
--     GTK+ 2.x:                    NO
--     GThread :                    NO
--     GtkGlExt:                    NO
--     OpenGL support:              NO
-- 
--   Media I/O: 
--     ZLib:                        build (ver 1.2.7)
--     JPEG:                        build (ver 62)
--     PNG:                         build (ver 1.5.12)
--     TIFF:                        build (ver 42 - 4.0.2)
--     JPEG 2000:                   build (ver 1.900.1)
--     OpenEXR:                     build (ver 1.7.1)
-- 
--   Video I/O:
--     DC1394 1.x:                  NO
--     DC1394 2.x:                  NO
--     FFMPEG:                      NO
--       codec:                     NO
--       format:                    NO
--       util:                      NO
--       swscale:                   NO
--       gentoo-style:              YES

The opencv libraries are build good, but the GTK for example it seems that is not build. Anyways I tried to compile my .cpp file which use the opencv libraries, I compile it like this:

 arm-linux-g++ -static -o exampleWindows IPCamera.cpp `pkg-config --cflags --libs opencv`

It compile without problem and I get the executable in ARM format, and with staic linker(as I want), but when I try to run in my ARM I get this error:

 OpenCV Error: Unspecified error (The function is not implemented. 
 Rebuild the library with Windows, GTK+ 2.x or Carbon support. 
 If you are on Ubuntu or Debian, install libgtk2.0-dev and pkg-config, 
 then re-run cmake or configure script) in cvNamedWindow, 
 file /home/jesus/opencv/opencv/modules/highgui/src/window.cpp, line 483
 terminate called after throwing an instance of 'cv::Exception'
 what():  /home/jesus/opencv/opencv/modules/highgui/src/window.cpp:483: error: (-2)    
 The function is not implemented.

So obviously I need to build the Cmake with this library but I do not know if I have to indicate the PATH for indicate where are this library in my PC when I build the CMake.

This is my command for build the CMake:

cmake -D SOFTFP=ON -D BUILD_SHARED_LIBS=OFF -D CMAKE_BUILD_TYPE=DEBUG -D WITH_TBB=ON -D BUILD_NEW_PYTHON_SUPPORT=ON -D WITH_V4L=ON -D INSTALL_C_EXAMPLES=ON -D INSTALL_PYTHON_EXAMPLES=ON -D BUILD_EXAMPLES=ON -D OPENCV_BUILD_3RDPARTY_LIBS=ON -D WITH_FFMPEG=ON -D WITH_GTK=ON -D WITH_OPENEXR=ON -D WITH_OPENNI=ON -D WITH_PNG=ON -D WITH_TBB=ON -D WITH_XINE=ON -D WITH_GSTREAMER=ON -D CMAKE_TOOLCHAIN_FILE=../opencv/platforms/linux/arm-gnueabi.toolchain.cmake ../opencv

Thank you so much.

edit retag flag offensive close merge delete