opencv(2.4.8) highgui +qt(5) creator()= segmentation fault.... Why?

asked 2014-02-20 12:33:55 -0500

hvit gravatar image

I use QtCreator(2.8) with Qt(5.1.1) in Linux(gcc-4.8) openSuse(13.1). When I add the "highgui" of the OpenCV(2.4.8) library then I get a SEGMENTATION FAULT. How can I solve this?

edit retag flag offensive close merge delete

Comments

I met the same problem. And I tried that opensuse 12.3 + opencv2.4.3 +qt5.2.1/5.1.1 or opensuse tumbleweed + opencv2.4.8 + qt5.2.1/5.1.1 are the same. Sometime enen including the highgui.cpp will rise an error without any opencv functions. but when i use qt4.8.4 in opensuse 12.3 with opencv2.4.3 ,if not include the QCoreApplication in a consolo project, the opencv shows the image correctly.

maybepossible gravatar imagemaybepossible ( 2014-03-19 06:13:58 -0500 )edit