OpenCV android - OpenCV manager won't load...

asked 2012-09-22 04:46:32 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >50 is welcome to improve it.

Hi!

I am having troubles running the android samples.

I have followed the instructions in link text and now able to compile the samples without errors.

But, when I try to run the samples, I keep getting the "OpenCV library package was not found" error...

I have installed the relevant .apk libraries in the emulator:

C:\Program Files (x86)\Android\android-sdk\platform-tools>adb install c:\OpenCV- 2.4.2-android-sdk\OpenCV-2.4.2-android-sdk\apk\OpenCV_2.4.2_Manager.apk 56 KB/s (386442 bytes in 6.653s) pkg: /data/local/tmp/OpenCV_2.4.2_Manager.apk Success

C:\Program Files (x86)\Android\android-sdk\platform-tools>adb install c:\OpenCV- 2.4.2-android-sdk\OpenCV-2.4.2-android-sdk\apk\OpenCV_2.4.2_binary_pack_armv5.ap k 56 KB/s (4327282 bytes in 75.027s) pkg: /data/local/tmp/OpenCV_2.4.2_binary_pack_armv5.apk Success

The 'Package Manager' is visible in the apps-section of the emulator and I am able to open the Package Manager app. the Package Manager reports that OCV 2.4 pack armeabi is installed.

What is wrong here??? When I run the Package Manager app the section "Device information" reports "Hardware: not detected". Could this be the problem??

Please help.

Kind regards,

Ole Storm.

Output from 'Console' when AVD was created:

[2012-09-22 10:58:24 - SDK Manager] Created AVD 'myMobile' based on Android 2.2, ARM (armeabi) processor, [2012-09-22 10:58:24 - SDK Manager] with the following hardware config: [2012-09-22 10:58:24 - SDK Manager] hw.lcd.density=240 [2012-09-22 10:58:24 - SDK Manager] vm.heapSize=24 [2012-09-22 10:58:24 - SDK Manager] hw.camera.back=emulated [2012-09-22 10:58:50 - OpenCV Tutorial 0 - Android Camera] ------------------------------ [2012-09-22 10:58:50 - OpenCV Tutorial 0 - Android Camera] Android Launch! [2012-09-22 10:58:50 - OpenCV Tutorial 0 - Android Camera] adb is running normally. [2012-09-22 10:58:50 - OpenCV Tutorial 0 - Android Camera] Performing org.opencv.samples.tutorial0.Sample0Base activity launch [2012-09-22 10:58:50 - OpenCV Tutorial 0 - Android Camera] Automatic Target Mode: launching new emulator with compatible AVD 'myMobile' [2012-09-22 10:58:50 - OpenCV Tutorial 0 - Android Camera] Launching a new emulator with Virtual Device 'myMobile' [2012-09-22 10:58:53 - OpenCV Tutorial 0 - Android Camera] New emulator found: emulator-5554 [2012-09-22 10:58:53 - OpenCV Tutorial 0 - Android Camera] Waiting for HOME ('android.process.acore') to be launched...

edit retag flag offensive close merge delete

Comments

This could be this problem: http://answers.opencv.org/question/1837

Kirill Kornyakov gravatar imageKirill Kornyakov ( 2012-10-10 01:46:05 -0500 )edit