qt 5.9.6 opencv ios pack failure

asked 2018-07-10 02:34:39 -0500

hello i just try to use opencv my ios project and i am newbee. i explain all my questions in qt forum and at the end they told me now you have to ask this part opencv expert so i write you

https://forum.qt.io/topic/92388/qt-op...

this is my question.

Starting remote process. OpenCV(3.4.1) Error: Unspecified error (The function is not implemented. Rebuild the library with Windows, GTK+ 2.x or Carbon support. If you are on Ubuntu or Debian, install libgtk2.0-dev and pkg-config, then re-run cmake or configure script) in cvShowImage, file /Volumes/build-storage/build/master_iOS-mac/opencv/modules/highgui/src/window.cpp, line 636 libc++abi.dylib: terminating with uncaught exception of type cv::Exception: OpenCV(3.4.1) /Volumes/build-storage/build/master_iOS-mac/opencv/modules/highgui/src/window.cpp:636: error: (-2) The function is not implemented. Rebuild the library with Windows, GTK+ 2.x or Carbon support. If you are on Ubuntu or Debian, install libgtk2.0-dev and pkg-config, then re-run cmake or configure script in function cvShowImage

Run ended.

so they told me i use framework right but framework has a problem about my code. they told me like that

Qt expert: As the error suggest, imshow's backend is not implemented for iOS but that's something you'd have to look with the OpenCV folks.

my answer: about error suggest, i just download opencv ios pack from opencv website as i told so i didnt understand that.

Qt expert: Building OpenCV for iOS by hand or using their pre-built package won't change anything: the highgui doesn't seem to have backend for iOS.

thanks for your time. best regards

edit retag flag offensive close merge delete