when i use sfm::reconstruct to extract the point cloud out of set of images it gives faulty 3D points (i already calibrated my camera and found the camera matrix) could the images be the problem and if so what should be done ?

asked 2018-06-12 02:51:18 -0500

gaber gravatar image

updated 2018-06-12 02:58:09 -0500

Generating point cloud from set of images

edit retag flag offensive close merge delete

Comments

How many images have you got in the set ?

LBerger gravatar imageLBerger ( 2018-06-12 08:44:22 -0500 )edit

6 images..

gaber gravatar imagegaber ( 2018-06-13 02:23:07 -0500 )edit

can you try with images here?

LBerger gravatar imageLBerger ( 2018-06-13 02:30:17 -0500 )edit

thank you so much i will try with them and then tell you the results

gaber gravatar imagegaber ( 2018-06-13 03:57:41 -0500 )edit

still the same problem could be a problem with the build of the library ?! it should give me a point cloud representing the scene , isnt it !? or there is something i miss understand ?

gaber gravatar imagegaber ( 2018-06-13 04:45:37 -0500 )edit

i build ceres without SuiteSparse , would that be the problem !?

gaber gravatar imagegaber ( 2018-06-13 08:15:05 -0500 )edit

I don't think so. Have yo run sample example_sfm_scene_reconstruction.exe ?

LBerger gravatar imageLBerger ( 2018-06-13 08:29:38 -0500 )edit

How to build sfm using cmake and my getbuilinformation it's here

LBerger gravatar imageLBerger ( 2018-06-13 08:52:47 -0500 )edit

i didnt build the examples i will build it again and build examples and show you my build information

gaber gravatar imagegaber ( 2018-06-13 18:16:39 -0500 )edit

thank you so much for your concern i really appreciate it

gaber gravatar imagegaber ( 2018-06-13 18:17:11 -0500 )edit